fbpx

Hardware instruments

Camelot supports ANY MIDI devices through standard MIDI messages. You can create your own “custom maps” to select presets and send special MIDI messages, if needed, grouped by Manufacturer / Device Model.

In addition, Camelot provides a long list of so-called “smart maps”. We are making a huge effort in making them for as many as possible MIDI devices like synths, keyboards, digital pianos, effect processors, mixers, and more. Devices that benefit of such smart maps allow an easier and better user experience because it is possible to control the device’s main features without knowledge of MIDI numbers, messages, channels, SysEx and so on.

Camelot provides a unified experience in managing all hardware devices, but each manufacturer and device offers a different MIDI implementation chart. That means that the number of features supported and the level of automations depend on the device and manufacturer.

Software instruments

Plugin host specifications

Camelot can host software instruments as plugins, depending on the operating system and the device.

macOS (AU, VST & VST3 - 64bit only)

Audio Units and VST 64bit plugin Instruments are supported. 32bit plugins are not supported. The Audio FX plugins are not supported yet. They will be available with the additional “Audio” module that will be released in late 2019.

macOS system requirements: macOS 10.10 or greater

Windows (VST, VST3 - 64bit only)

VST 64bit plugin Instruments are supported. 32bit plugins are not supported. The Audio FX plugins are not supported yet. They will be available with the additional “Audio” module that will be released in late 2019.

Windows system requirements: Windows 7 or above

 

iOS (iPad) (AUv3)

Audio Units V3 plugin Instruments are supported. Other formats are not supported yet. We are working with Audiobus team to provide a smart integration between our systems. The Audio FX plugins are not supported yet. They will be available with the additional “Audio” module that will be released in late 2019.

iOS requirements: IOS 10.3* or greater

*iOS 10.3 limited support: attachments import, backup files import/export, .syx files import not allowedDo not purchase Camelot if you need such features on your 10.3 iPad)

Coming soon
  • Audio Plugin support (Effects)
  • Backing Tracks
  • Control Surface support

Operating systems

macOS (laptop and desktop)

Camelot runs on macOS 10.10 or greater

Running Camelot is not very demanding in terms of system resources, everything depends on the type and number of plugin instruments that are loaded. The MIDI management for the hardware device is pretty light.

Recommended system:

CPU: Intel Core i5 –  2.2 GHz

RAM: 8.00 GB

Supported plugin formats:

Audio Units, VST, VST3 – 64 bit only

Windows (Laptop and Desktop)

Camelot runs on Windows 7 and above, 64bit only

Running Camelot is not very demanding in terms of system resources, everything depends on the type and number of plugin instruments that are loaded. The MIDI management for the hardware device is pretty light.

Recommended system:

CPU: Intel Core i5 –  2.0 GHz

RAM: 4.00 GB

Supported plugin formats:

VST, VST3 – 64 bit only

iOS (iPad only)

Camelot runs on iPad with iOS 10.3* or greater.

Running Camelot is not very demanding in terms of system resources, everything depends on the type and number of plugin instruments that are loaded. The MIDI management for the hardware device is pretty light.

Supported plugin formats:

AUv3

(InterAppAudio – IAA and AudioBus are not supported, yet, but they are on our plans)

 

*iOS 10.3 limited support: attachments import, backup files import/export, .syx files import not allowed. Do not purchase Camelot if you need such features on your 10.3 iPad)

Coming soon
  • Android Version is on our roadmap
  • iPhone Version is on our roadmap